[Commits] Rev 93: Fix makefile rule to select correct libevent depending on distro release. in http://bazaar.launchpad.net/~maria-captains/maria/5.1

knielsen at knielsen-hq.org knielsen at knielsen-hq.org
Mon Nov 22 16:38:41 EET 2010


At http://bazaar.launchpad.net/~maria-captains/maria/5.1

------------------------------------------------------------
revno: 93
revision-id: knielsen at knielsen-hq.org-20101122143841-4a7x3gqna20xatid
parent: knielsen at knielsen-hq.org-20101122115629-4fi6f4mgoh2rjwxe
committer: knielsen at knielsen-hq.org
branch nick: ourdelta-bugfix
timestamp: Mon 2010-11-22 15:38:41 +0100
message:
  Fix makefile rule to select correct libevent depending on distro release.
=== modified file 'bakery/debian-5.1/dist/Debian/rules'
--- a/bakery/debian-5.1/dist/Debian/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.1/dist/Debian/rules	2010-11-22 14:38:41 +0000
@@ -40,10 +40,10 @@ USE_ASSEMBLER=--enable-assembler 
 
 # From Debian Squeeze we can use system libevent. But before that,
 # system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 4 5))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 4 5))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))

=== modified file 'bakery/debian-5.1/dist/Ubuntu/rules'
--- a/bakery/debian-5.1/dist/Ubuntu/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.1/dist/Ubuntu/rules	2010-11-22 14:38:41 +0000
@@ -46,10 +46,10 @@ MYSQL_BUILD_CXXFLAGS = -O2 -fno-omit-fra
 
 # From Ubuntu 9.10 "Karmic" we can use system libevent. But before
 # that, system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 8.04 8.10 9.04))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 8.04 8.10 9.04))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))

=== modified file 'bakery/debian-5.2/dist/Debian/rules'
--- a/bakery/debian-5.2/dist/Debian/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.2/dist/Debian/rules	2010-11-22 14:38:41 +0000
@@ -40,10 +40,10 @@ USE_ASSEMBLER=--enable-assembler 
 
 # From Debian Squeeze we can use system libevent. But before that,
 # system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 4 5))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 4 5))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))

=== modified file 'bakery/debian-5.2/dist/Ubuntu/rules'
--- a/bakery/debian-5.2/dist/Ubuntu/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.2/dist/Ubuntu/rules	2010-11-22 14:38:41 +0000
@@ -46,10 +46,10 @@ MYSQL_BUILD_CXXFLAGS = -O2 -fno-omit-fra
 
 # From Ubuntu 9.10 "Karmic" we can use system libevent. But before
 # that, system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 8.04 8.10 9.04))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 8.04 8.10 9.04))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))

=== modified file 'bakery/debian-5.3/dist/Debian/rules'
--- a/bakery/debian-5.3/dist/Debian/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.3/dist/Debian/rules	2010-11-22 14:38:41 +0000
@@ -40,10 +40,10 @@ USE_ASSEMBLER=--enable-assembler 
 
 # From Debian Squeeze we can use system libevent. But before that,
 # system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 4 5))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 4 5))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))

=== modified file 'bakery/debian-5.3/dist/Ubuntu/rules'
--- a/bakery/debian-5.3/dist/Ubuntu/rules	2010-11-22 11:56:29 +0000
+++ b/bakery/debian-5.3/dist/Ubuntu/rules	2010-11-22 14:38:41 +0000
@@ -46,10 +46,10 @@ MYSQL_BUILD_CXXFLAGS = -O2 -fno-omit-fra
 
 # From Ubuntu 9.10 "Karmic" we can use system libevent. But before
 # that, system libevent is too old, and we must use bundled.
-ifneq (,$(filter $(RELEASE), 8.04 8.10 9.04))
-    USE_LIBEVENT=--with-libevent=/usr
-else
+ifneq (,$(findstring $(RELEASE), 8.04 8.10 9.04))
     USE_LIBEVENT=--with-libevent
+else
+    USE_LIBEVENT=--with-libevent=/usr
 endif
 
 ifneq (,$(filter $(ARCH), amd64 i386 ia64 s390))



More information about the commits mailing list